Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
H3D.org Feeds


Browsing this Thread:   1 Anonymous Users






Freeglut error when starting Quadbufferstereo application
#1
Quite a regular
Quite a regular


See User information
Hi!

Background:
Latest H3D-version compiled with the vs2015 Externals.
Uses Nvidia Vision 3D with Quad Buffer Stereo
Worked like a week ago when compiling it together.
Starting the application without quad buffer stereo does work as usual...

Error text:
freeglut (H3DLoad): ERROR: No display callback registered for window 1.

Any ideas to solve this? :)

Posted on: 10/10 15:21
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Freeglut error when starting Quadbufferstereo application
#2
Webmaster
Webmaster


See User information
Latest trunk that is I assume?
So you got an updated freeglut build?
Please just revert External freeglut to a previous version and see if it works then.
If so then we need to figure out what is missing.

Otherwise please update H3DAPI to a previous revision as well.

Posted on: 10/11 13:47
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Freeglut error when starting Quadbufferstereo application
#3
Quite a regular
Quite a regular


See User information
Yes, latest trunk version of H3D!
Revision 479 of the externals seems to be an upgrade of freeglut to 3.0.0 and from there the problems starts. 478 works fine as before! I did not revert H3DAPI in the testing!


Posted on: 10/11 14:21
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Freeglut error when starting Quadbufferstereo application
#4
Webmaster
Webmaster


See User information
Then the problem was as I guessed.
Use the old freeglut until we have dealt with it then.
Will set it up in our task management system.

Posted on: 10/11 15:54
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Freeglut error when starting Quadbufferstereo application
#5
Webmaster
Webmaster


See User information
Hello,

We had to revert to previous revisions of freeglut due to some kind of bug. Please update External and try now.

Posted on: 10/16 9:39
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Freeglut error when starting Quadbufferstereo application
#6
Quite a regular
Quite a regular


See User information
Hi,
Yeah I saw that this morning when i got to the Office. Updated the Externals and using it now! Thx for the update!

Posted on: 10/16 10:21
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.
You cannot create pdf.
You cannot get print page.

[Advanced Search]





(C) 2012 SenseGraphics AB    ---    Powered by XOOPS