Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
H3D.org Feeds


Browsing this Thread:   1 Anonymous Users






URL not loading
#1
Just popping in
Just popping in


See User information
I am trying to puzzle out why I get the error: "none of the urls in ScalarVolume with url ["skull.raw"] could be loaded" when trying to load the following code H3DViewer.

<Group>
  <
VolumeRenderer>
     <
Texture3DVolume property="SCALAR">
    <
ScalarVolume DEF="SCALAR" url="skull.raw">
        <
ManipImageLoader padding="false">
               <
RawImageLoader 
                  width
="256" height="256" depth="256"
          
bitsPerPixel="8"
          
pixelType="LUMINANCE"
          
pixelComponentType="UNSIGNED"
          
pixelSize="1 1 1" />
         </
ManipImageLoader>
        </
ScalarVolume>
     </
Texture3DVolume>
  </
VolumeRenderer>
</
Group>


But all works fine with this code

<Group>
   <
VolumeData>
     <
Image3DTexture containerField="voxels" url="skull.raw">
    <
RawImageLoader
             width
="256" height="256" depth="256"
             
bitsPerPixel="8"
         
pixelType="LUMINANCE"
         
pixelComponentType="UNSIGNED"
         
pixelSize="1 1 1" />
    </
Image3DTexture>
    </
VolumeData>
</
Group>


Yes, I do know that in the first instance I am using VHTK nodes and in the other MedX3D nodes, but the loader is the same (I think). BTW, I get the same behavior if I use the DICOM version of the data ("skull66.dcm") and the DicomImageLoader.

Any thoughts?

My thanks in advance.

Posted on: 2011/1/18 21:33
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: URL not loading
#2
Guru
Guru


See User information
I'm doing that same thing without problems. Is it the same program executed from the same folder? No change of relative paths or so?

Posted on: 2011/1/21 8:13
KJ Lundin Palmerius
C Research
Linköping University, Sweden
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: URL not loading
#3
Just popping in
Just popping in


See User information
Both programs and the data are in the same folder. Both are being run from (loaded into H3DViewer) from the same directory. I'm fairly sure that there is something subtle that I'm missing - I just don't see what it is.

Posted on: 2011/1/24 16:08
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: URL not loading
#4
Guru
Guru


See User information
Could you try H3DLoad instead? I'm not sure how H3DViewer is handling folders.

Posted on: 2011/1/25 10:35
KJ Lundin Palmerius
C Research
Linköping University, Sweden
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.
You cannot create pdf.
You cannot get print page.

[Advanced Search]





(C) 2012 SenseGraphics AB    ---    Powered by XOOPS