Login
Username:

Password:

Remember me



Lost Password?

Register now!
Main Menu
H3D.org Feeds


Browsing this Thread:   1 Anonymous Users






Problems using OpenAL!!
#1
Quite a regular
Quite a regular


See User information
I want to play sounds during my H3D simulation and for this purpose I am using OpenAL functions. But even after installing OpenAL libraries (avaialable with the H3Dapi Windows installer) and including the header files properly I am getting errors namely "unresolved external symbol errors":

XXX.obj error LNK2019unresolved external symbol __imp__alcOpenDevice referenced in function "public: __thiscall H3D::Function_name1::Function_name2(struct H3D::Inst<class H3D::SFNode>,struct H3D::Inst<class H3D::H3DBoundedObject::SFBound>,struct H3D::Inst<class H3D::X3DGeometryNode::DisplayList>,struct H3D::Inst<class H3D::SFFloat>,struct H3D::Inst<class H3D::SFInt32>,struct H3D::Inst<class H3D::SFInt32>,struct H3D::Inst<class H3D::SFInt32>,struct H3D::Inst<class H3D::MFString>,struct H3D::Inst<class H3D::MarchingCubesPointShell::MC_Update>,struct H3D::Inst<class H3D::SFVec3f>,struct H3D::Inst<class H3D::SFFloat>,struct H3D::Inst<class H3D::SFVec3f>,struct H3D::Inst<class H3D::SFBool>,struct H3D::Inst<class H3D::SFBool>,struct H3D::Inst<class H3D::SFFloat>,struct H3D::Inst<class H3D::SFVec3f>,struct H3D::Inst<class H3D::SFVec3f>,struct H3D::Inst<class H3D::SFVec3f>,struct H3D::Inst<class H3D::SFVec3f>,struct H3D::Inst<class H3D::SFRotation>,struct H3D::Inst<class H3D::SFColor>,struct H3D::Inst<class H3D::SFRotation>,struct H3D::Inst<class H3D::SFMatrix4f>,struct H3D::Inst<class H3D::SFMatrix4f>,struct H3D::Inst<class H3D::SFInt32>,struct H3D::Inst<class H3D::SFFloat>)"


Can anyone please tell me how to solve these issues. Thanks.

Posted on: 2016/10/20 7:29
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Problems using OpenAL!!
#2
Webmaster
Webmaster


See User information
Is XXX.obj in a dll which you have created? Or did you just add it to C++ or is it just H3D classes and you just removed which file was missing it?

If it is your own classes in your dll then just make sure you are linking against the correct library (.lib) as well, headers are checked during the compile stage and libraries when linking.

Posted on: 2016/10/20 7:58
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Problems using OpenAL!!
#3
Quite a regular
Quite a regular


See User information
Thank you for your reply!!
Yes XXX.obj is in a dll which I am creating for my application!

Posted on: 2016/10/20 8:44
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.
You cannot create pdf.
You cannot get print page.

[Advanced Search]





(C) 2012 SenseGraphics AB    ---    Powered by XOOPS